Jump to content

Destination sign FAIL !


eclair14
 Share

Recommended Posts

  • 3 weeks later...
  • 3 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 2 months later...

I have two things here.

1) I seem to have this happen when attempting to get photos of LED signs:

5528525682_de75c1dce4_m.jpg

Sound Transit LINK 110 by zargoman, on Flickr

And there was this one:

5531585030_1b99849a68_m.jpg

King County Metro 2009 New Flyer DE60LFA 6002 by zargoman, on Flickr

Both of these signs were completely fine when I took the photos, but the camera didn't agree with them for some reason. I've had the same happen in the past with LED tail lights.

Another complete FAIL that was done either by New Flyer or King County Metro is this:

5493240728_b4ca6be6ca_m.jpg

6081? I think not by zargoman, on Flickr

There is no such thing as coach 6081 in Metro's fleet. Their DE60LFAs are currently 6000-6020.

Link to comment
Share on other sites

  • 8 months later...
  • 1 month later...

Bumping this post with a few older fails from the TTC... :P

Screwed up RTS -

http://www.majhost.c...ls/img_0543.jpg

Screwed up D40LF -

http://www.majhost.c...ls/dsc00663.jpg

An a video of an offset New Look sign, which used to be somewhat common. At the very start of the idea, the sign reads "52 Lawrence We"

http://www.youtube.c...h?v=kNFilxq0AOQ

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 1 year later...
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...