Jump to content

Wiki Photo Uploading Error


D. DeLarge
 Share

Recommended Posts

I tried to uploading a photo to the wiki and received...

"Warning: escapeshellarg() has been disabled for security reasons in /home/cptdbca/public_html/wiki/includes/GlobalFunctions.php on line 1120"

As well as this where the photo should be:

"Error creating thumbnail: <br />

<b>Warning</b>: passthru() has been disabled for security reasons in <b>/home/cptdbca/public_html/wiki/includes/GlobalFunctions.php</b> on line <b>2030</b><br />"

http://www.cptdb.ca/wiki/index.php/Image:C...oach_2621-a.jpg

Link to comment
Share on other sites

Yeah, there have been a few photos uploaded successfully from different people.

I see the new error on that particular photo is Error creating thumbnail: sh: /usr/bin/convert: No such file or directory

which does help me. Thanks.

Link to comment
Share on other sites

Hmmm, it seems a few of the other photos were uploaded as 800x600. I uploaded a larger resolution (1024x5xx), and it turns out the photo was uploaded to the Wiki but it didn't create a smaller 800x600 thumbnail for it.

Link to comment
Share on other sites

Hmm...I got this while uploading a photo of 2044 just now:

Error creating thumbnail: convert: unable to open image `/home/cptdbca/public_html/wiki/images/thumb/3/37/York_Region_Transit_2044.jpg/800px-York_Region_Transit_2044.jpg': Permission denied @ blob.c/OpenBlob/2403.

http://www.cptdb.ca/wiki/index.php/Image:Y...ransit_2044.jpg

Link to comment
Share on other sites

Hmm...I got this while uploading a photo of 2044 just now:

Error creating thumbnail: convert: unable to open image `/home/cptdbca/public_html/wiki/images/thumb/3/37/York_Region_Transit_2044.jpg/800px-York_Region_Transit_2044.jpg': Permission denied @ blob.c/OpenBlob/2403.

http://www.cptdb.ca/wiki/index.php/Image:Y...ransit_2044.jpg

Looks like it's back...you image did upload.

Link to comment
Share on other sites

I was just uploading a bunch of TTC maps (starting today with route 41), they all worked fine except when I uploaded route 47 (http://www.cptdb.ca/wiki/index.php/Image:T...map_current.gif) it comes out with an error: "Error creating thumbnail:" inside a grey box the same size as the map (it just ends with the colon, no reason given for the error). When linking to the photo however it works fine.

EDIT: The image works for vivablue5215... perhaps this issue is restricted just to the uploader?

Link to comment
Share on other sites

Got another error recently:

Warning: copy(/home/cptdbca/public_html/wiki/images/temp/1/19/20090616220429!Brampton_Transit_8500-b.jpg) [function.copy]: failed to open stream: Permission denied in /home/cptdbca/public_html/wiki/includes/filerepo/FSRepo.php on line 200

Could not copy file "/tmp/phpAwKiyv" to "temp/1/19/20090616220429!Brampton_Transit_8500-b.jpg".

I uploaded a photo about an hour earlier and it worked fine though.

Link to comment
Share on other sites

This this message this morning while lloking at a TTC Orion 05.501..

Error creating thumbnail: convert: unable to open image `/home/cptdbca/public_html/wiki/images/thumb/4/45/Toronto_Transit_Commission_7070.jpg/1024px-Toronto_Transit_Commission_7070.jpg': Permission denied @ blob.c/OpenBlob/2403.

Link to comment
Share on other sites

Got another error recently:

Warning: copy(/home/cptdbca/public_html/wiki/images/temp/1/19/20090616220429!Brampton_Transit_8500-b.jpg) [function.copy]: failed to open stream: Permission denied in /home/cptdbca/public_html/wiki/includes/filerepo/FSRepo.php on line 200

Could not copy file "/tmp/phpAwKiyv" to "temp/1/19/20090616220429!Brampton_Transit_8500-b.jpg".

I uploaded a photo about an hour earlier and it worked fine though.

I don't know why, but certain photos I try to upload I keep getting this error.

In addition to the above, I get:

Internal error

From CPTDB Wiki

Jump to: navigation, search

Link to comment
Share on other sites

Can you email me one of those photos giving you trouble? (admin@cptdb.ca)

With a new version of the Invision Board software out, I might just wait to get that installed from scratch and hope everything is fixed in the process. :P

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...